Назначение

Конфигуратор CANPort v.2.0

(далее - Конфигуратор) предназначен для настройки универсального CAN устройства CANPort.

Конфигуратор имеет два режима работы ( обмен информацией с CANPort происходит по CAN шине):

1. режим работы с помощью CAN анализатора.

В этом режиме конфигуратор по данным настроек сделанных в программе, формирует специальные CAN сообщения с помощью которых можно изменить настройки в CANPort.

Настройки CANPort возможно изменить только, если он находиться в режиме конфигурации!

Для настройки нужно подключить CANPort к CAN анализатору, настроить анализатор на скорость CAN шины 500 kbps и ввести устройство в режим конфигурации.

ВВОД В РЕЖИМ КОНФИГУРАЦИИ

Удерживая кнопку на корпусе устр-ва подать питание на устр-во. Светодиод мигнет четыре раза и CANPort начнёт посылать в шину информационное сообщение:

свидетельствуя о том, что он находится в режиме конфигурации…. то есть готов к приему команд.

Последние два байта в данном сообщении показывают оставшийся лимит работы устройства, в данном случае данные АА АА указывают что лимит работы не установлен, то есть CANPort работает без ограничений по времени работы.

Схема подключения CANPort при конфигурировании с помощью кан анализатора

Подключение к разъему CANPort (стандарт OBD II )

разъем "мама" - встречная часть разъема CANPort

4 ; 5 минус (подключить к любому из двух)

16 питание +12В

6 линия CAN-High

14 линия CAN-Low

2. Режим работы через интерфейс CANPort USB Flasher.

В режиме работы через интерфейс CANPort USB Flasher питание подается автоматически с флешера, подавать отдельное питание на CANPort не нужно, ввод в режим конфигурации не требуется.

Схема подключения CANPort при конфигурировании с помощью CANPort USB Flasher

Нажмите кнопку "Установить связь с CANPort ом" При правильном пароле конфигуратор установит связь с CANPort, прочтёт с него данные и сообщит в окне об успешном чтении

Установите нужные настройки во всех вкладках программы и нажмите кнопку "Записать в CANPort"

Конфигуратор начнёт запись настроек в CANPort, отображая процесс в строке прогресса.

При успешной записи, конфигуратор сообщит в окне:

Created with the Personal Edition of HelpNDoc: Full featured Documentation generator

Copyright © 2012. CAN Технологии. www.can-device.ru


Вкладки настроек

Окна программы

При запуске окно программы имеет такой вид:

нижняя часть программы (информационное окно) для режима работы с помощью CAN анализатора.

1. Кнопки сохранения созданной конфигурации в файл и выбора файла конфигурации прошивки для открытия в программе Конфигуратора.

2. Статус подключения интерфейса CANPort USB Flasher к компьютеру.

3. Записать выбранный файл конфигурации (данные файла отображаются в основных окнах) или конфигурацию настроенную в основных окнах программы. (активна только после установки связи с CANPort).

4. Строка прогресса (отображает процесс установки связи и записи).

5. Кнопка "Установить связь с CANPort ом". (активна только если CANPort USB Flasher Подключен).

6. Поле для ввода пароля смены настроек CANPort (по умолчанию FFFFFF).

7. Справка программы.

8. Вкладки настроек.

9. Данные выбранной вкладки настроек.

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Установка лимита

Вкладки настроек ››

Установка лимита времени работы CANPort.

На этой вкладке можно задать время работы CANPort, после истечения этого времени работа устройства блокируется до переустановки нового лимита времени работы.

Если установить галку на "безлимит" CANPort будет работать без ограничения по времени работы.

Для режима работы с CAN анализатором:

В нижней части окна после установки лимита и нажатия на кнопку "Показать посылку" будет показано can сообщение которое нужно отправить в CANPort, CANPort должен находиться в режиме конфигурации .

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Смена сообщений

Вкладки настроек ››

Смена сообщений (запись в CANPort нужных нам сообщений)

На этой вкладке указываем какие именно сообщения нужно записать в CANPort (сообщения которые будет транслировать CANPort после подачи на него питания).

Возможные настройки:

1. Количество сообщений (до 8 сообщений).

2. Необходимый тайминг сообщений (через какие промежутки времени будут транслироваться записываемые сообщения в том же порядке как мы видим в окне данных)

3. Скорость шины CAN.

4. Инкремент данных. (доступно тольки при работе через интерфейс CANPort USB Flasher )

5. ....и конечно же сами сообщения в окне данных.(ввод данных в это окно необходим только в режиме работы через интерфейс CANPort USB Flasher )

В случае если необходимо записать сообщение с расширенным ID нужно выставить галку в столбце "Ext".

Инкремент данных.

Если щелкнуть правой кнопкой мыши в ячейке данных эта ячейка окрасится в желтый цвет.

CANPort после записи в него такой конфигурации в рабочем режиме будет при каждой следующей отправке данного сообщения инкрементировать байт данных в закрашенной ячейке. То есть в нашем примере сообщение с ID 420 будет отправляться в таком порядке:

420 5 FF 00 FF 00 FF

420 5 FF 00 FF 01 FF

420 5 FF 00 FF 02 FF

420 5 FF 00 FF 03 FF

420 5 FF 00 FF 04 FF

....

420 5 FF 00 FF FE FF

420 5 FF 00 FF FF FF

420 5 FF 00 FF 00 FF и т.д.

Для режима работы с CAN анализатором:

В нижней части окна после установки настроек, и нажатия на кнопку "Показать посылку" будет показано can сообщение которое нужно отправить в CANPort находящийся в режиме конфигурации .

Если сообщение корректно, CANPort перейдёт в режим записи сообщения \ сообщений (если количество требуемых посылок более одного). Причем CANPort транслирует сообщение с информационным ID 111 в котором сообщает какое количество сообщений CANPort ожидает для записи. Светодиод моргнет два раза и останется светящимся.

Теперь мы отправляем в CANPort сообщение которое мы бы хотели получать от CANPort в рабочем режиме, сообщение может иметь разный ID, разное количество байт.
После записи каждого сообщения CANPort отправляет контрольное сообщение содержащее записанные данные.
После окончания приёма последнего сообщения светодиод на корпусе CANPort моргнёт три раза и потухнет. Окно принимаемых сообщений CAN анализатора после записи трех сообщений будет выглядеть примерно так:

В окне Transmit (Передача) можно увидеть в какой последовательности отправлялись сообщения в CANPort:

Первое сообщение с ID 333 - сообщение (в котором закодированы настройки данных) выданное нам конфигуратором, после чего отправлялись необходимые нам сообщения.

В окне Receive (Приём) видим служебное сообщение с ID 111 и продублированные по одному разу записанные в CANPort сообщения.

сообщения в окне Receive отсортированы по увеличению и показаны не по порядку поступления

Created with the Personal Edition of HelpNDoc: Full featured Documentation generator


Установка события

Вкладки настроек ››

Установка события (по которому CANPort начнет транслировать сообщения)

На этой вкладке можно задать событие по которому CANPort начнет свою работу.

Если установлено событие - CANPort после подачи на него питания ждет появления:

1. заданного количества сообщений (кол-во сравнений),

2. с заданным ID

3. содержащие заданные (выделение красным) данные.

Пока CANPort не получит событие, он не начнет отправку записанных в него сообщений.

Данным действием мы можем защитить CANPort от несанкционированного чтения, записанных в него сообщений

Если указать только ID и не выделять данные в сообщении CANPort будет отслеживать сообщения с заданным ID не зависимо какие данные содержит сообщение.

Для режима работы с CAN анализатором:

В нижней части окна после установки количества сравнений, выделения данных для сравнения и нажатия на кнопку "Показать посылку" будет показано can сообщение которое нужно отправить в CANPort находящийся в режиме конфигурации .

Если сообщение корректно, CANPort перейдёт в режим записи сообщения события. Светодиод моргнет два раза и останется светящимся.
После чего можно отправить сообщение события, которое запишется в CANPort.

Окно CAN анализатора будет выглядеть так:

В окне Transmit (Передача) можно увидеть в какой последовательности отправлялись сообщения в CANPort:

Первое сообщение с ID 555 - сообщение (в котором закодированы настройки данных) выданное нам программой, после чего было отправлено сообщение события.

В окне Receive (Приём) видим служебное сообщение с ID 111 и продублированное один раз записанное в CANPort сообщение события

Created with the Personal Edition of HelpNDoc: Full featured Documentation generator


Смена пароля

Вкладки настроек ››

Смена пароля

На этой вкладке можно установить или сменить пароль для доступа к настройкам CANPort.

По умолчанию пароль установлен FF FF FF.

Для режима работы с CAN анализатором:

В нижней части окна после установки галки "Сменить пароль" и нажатия на кнопку "Показать посылку" будет показано can сообщение которое нужно отправить в CANPort находящийся в режиме конфигурации .

После отправки выданного программой сообщения светодиод на CANPort мигнет два раза.

После смены пароля и выключения питания CANPort , доступ к его настройкам будет возможен только с новым паролем!

Created with the Personal Edition of HelpNDoc: Full featured Documentation generator


Примечания

Вкладки настроек ››

Примечания

На данной вкладке можно записать свои примечания к данной конфигурации.

Текст примечания сохранится в файле конфигурации ( кнопка 1 ).

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Файлы конфигурации

Вкладки настроек ››

Конфигуратор сохраняет настройки в файл конфигурации с расширением cfg., что позволяет создавать базу файлов с заранее настроенными параметрами, а так же с описаниями к ним.

При наличии интерфейса CANPort USB Flasher и конфигурационных файлов, программирование CANPort значительно упрощается.

Файл конфигурации с расширением cfg имеет иконку

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Индикатор CANPort

Светодиодный индикатор CANPort . (расшифровка сигналов)

На торце корпуса CANPort находится светодиодный индикатор, по которому можно определить состояние CANPort.

Индикация стандартных режимов

Не светится - нет питания на CANPort. (после подачи питания нужно подождать 4 секунды)

Мигает - рабочий режим, CANPort транслирует сообщения в can шину.

Светится постоянно - CANPort ожидает сообщение события в can шине, после получения заданного количества сообщений события переходит в рабочий режим.

Мигнул и потух - исчерпан лимит работы .

Индикация при работе с CANPort USB Flasher (программирование)

Светится постоянно - процесс установки связи с CANPort (после установки связи не светится)

Частое мигание - запись данных в CANPort

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Связаться с нами

http://can-device.ru/

contacts@can-device.ru

Created with the Personal Edition of HelpNDoc: Full featured Documentation generator


Товары

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


CANPort USB Flasher

Товары ››

CANPort USB Flasher

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


CANPort

Товары ››

CANPort

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source